UNAGI ALEPH

Java runtime environment of 1.6 or later is required to play.

To play, first Download and extract the installation wherever you like. Execute "run.bat", and the game will update and launch itself automatically thanks to the magic of Getdown.